Does WITCustomControl 1.3.25 work on VS2017 and TFS 2015 update3

Topics: Developer Forum, Project Management Forum, User Forum
Mar 9 at 4:00 PM

I have TFS version - 2015 and update 3

Visual studio version 2017

I've installed latest of of WITCustomControl ( to populate the values that I have for custom control.

Error message is - Could not find a part of the path 'C:\ProgramData\Microsoft\Team Foundation\Work Item Tracking\Custom Controls\15.0\MultiValueControl.wicc'.

Does anyone else experience this and found a workaround?
Mar 10 at 12:48 PM
Me too. Same error with 2017
Mar 16 at 8:53 PM
Edited Mar 16 at 8:54 PM
I was able to create a 2017 compatible version by
  1. download the source
  2. update the Team Services binaries to those referenced in the visual studio 2017 extensions folder
  3. update the installer to install to the \15.0 folder instead of \14.0
I have uploaded my code as a patch, and hopefully it will be merged and released soon.

If you are brave, you can download it from the patches
Marked as answer by noblemathew27 on 3/23/2017 at 9:55 AM
Mar 23 at 5:55 PM
Thanks Dennis. That did help
Apr 25 at 8:17 PM
I'm having a similar problem:

Could not load file or assembly 'Microsoft.TeamFoundation.WorkItemTracking.Controls, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

I'm currently using visual studio 2017. Would the same solution above work for me? I may need to have step 2 spelled out a bit more.
Jun 21 at 3:19 PM
Thanks Dennis. It worked for me.