1
Vote

TFS 2015 2.1 MultiValueControl on WebAccess won't load

description

I have installed the Visual Studio 2015 plugin and the MultiValueControl works fine.

When I go to our tfs website my control displays the text 'Cannot create work item control of type "MultiValueControl"'.

When I inspect it in the browser I get these 2 errors:
  1. Failed to load resource: the server responded with a status of 404 (Not Found)
    basejs:53 Uncaught Error: Script error for: WorkItemTracking/Scripts/Controls/WorkItemForm/WorkItemControl
    http://requirejs.org/docs/errors.html#scripterror
  2. http://<ourserver>/tfs/_static/tfs/Dev14.M95.4/_scripts/TFS/min/WorkItemTracking/Scripts/Controls/WorkItemForm/WorkItemControl.js
    Failed to load resource: the server responded with a status of 404 (Not Found)
I have installed and enabled CodePlex.WitCustomControls Version 1.3.2.4 through <ourserver>/tfs/_admin/_extensions (the tab is now labeled Legacy Extensions)

Our TFS box is on a server in our local server room.

my control in the work item xml is:
<FIELD name="triag" refname="mycompany.triag" type="String"> 
    <SUGGESTEDVALUES expanditems="false">
        <LISTITEM value="[Approved]" />
        <LISTITEM value="[Investigate]" />
        <LISTITEM value="[Rejected]" />
        <LISTITEM value="[Submit]" />
    </SUGGESTEDVALUES>
</FIELD>


 <Control FieldName="mycompany.triag" Type="MultiValueControl" Label="Triag" LabelPosition="Left" />
Thanks in advance

comments

mmanela wrote Oct 25, 2016 at 4:28 PM

The web version of build 1.3.2.4 is only supported for TFS "15" RC1 or newer. Is that what you are using?

jrp77nj wrote Nov 7, 2016 at 2:43 PM

We are having this same issue. We migrated from TFS 2013 this weekend an I uninstalled the old version an installed version 1.3.2.4 this am and we receive this error.

http://<ourserver>/tfs/_static/tfs/Dev14.M102/_scripts/TFS/min/WorkItemTracking/Scripts/Controls/WorkItemForm/WorkItemControl.js 404 (Not Found)

We are running TFS version 14.102.25423.0 (Tfs2015.Update3)

mmanela wrote Nov 16, 2016 at 3:57 PM

The version is only support in TFS 2017 RC1 or newer

surese56 wrote Feb 2 at 8:26 PM

I have used the code as it is and still I'm not able to get it working
On the webpage it says Cannot create work item control of type "MultiValueControl".

Browser log says Uncaught TypeError: Cannot read property 'prototype' of undefined
which points to line domElem = VSS.UI.domElem;

Not sure what am I missing.
All the other workitem custom controls I wrote have the same problem.