Problems with new Process template Editor and Custom Control

Topics: Developer Forum
Feb 28, 2007 at 7:27 AM
Hi!

I just tried out the new Power Tools, and especially the Process Template Editor (PTE).
When trying to read a Work Item that uses the DuplicateId CustomControl that Naren posted it complains that it is an error, and the error in the Event Viewer says "WorkItemIdReference is not a valid value for ValidControlTypes".

Does this mean that the PTE cannot handle Custom Controls, or handles Custom Controls in a different manner?
It would be bad if it does not handle Custom Controls since we are using one and are trying to find time to develop at least one more...

/Tomas Scott
Jun 20, 2007 at 12:42 PM
Hi

I bumped into the same issue. Is there a new version of the process editor in the making that would handle this? else custom controls are of little value to us.

Brumlemann
Software Architect
Confirmit


tscott wrote:
Hi!

I just tried out the new Power Tools, and especially the Process Template Editor (PTE).
When trying to read a Work Item that uses the DuplicateId CustomControl that Naren posted it complains that it is an error, and the error in the Event Viewer says "WorkItemIdReference is not a valid value for ValidControlTypes".

Does this mean that the PTE cannot handle Custom Controls, or handles Custom Controls in a different manner?
It would be bad if it does not handle Custom Controls since we are using one and are trying to find time to develop at least one more...

/Tomas Scott

Jul 24, 2007 at 10:47 PM
I propose a workaround until the Powertools team releases a version of PTE that supports custom controls (it must be in the works).

I maintain two versions of any Work Item Type XML I'm working on. The working copy is one with placeholders for Custom Controls (choose whatever placeholder works best for you), and the other WIT XML version I generate with a search and replace script that replaces PTE supported controls (marked for replacement with a particular property or flag) with the actual XML tag for the custom control. The rough copy is what I view in PTE and the script generated copy is the one I upload to the server for testing.

There isn't much point to trying to test custom controls in the PTE form preview anyway as it has limited functionality and is meant only to preview the layout.