TFS 2015 Update 3

Topics: Developer Forum
Jun 29, 2016 at 9:01 PM
Edited Jul 5, 2016 at 8:39 PM
I hate to ask, but...

Should we expect an update for 2015 Update 3? I could not get this to work with 2015 2.1, and IN know the component was updated/rebuilt for 2.0. Thanks.
Developer
Jun 29, 2016 at 11:03 PM
Edited Jun 29, 2016 at 11:03 PM
I was expecting the controls to work for update 3 (and 2.1) but I'll run some tests tomorrow to see what it looks like.
Jul 5, 2016 at 8:38 PM
Any word on this? Thanks.
Developer
Jul 5, 2016 at 9:11 PM
Thanks for reminding. I just tested on 2015 Update 2.1 and Update 3 and it works fine on these setups. Can you share more of the issue you're experiencing?

Here's an example definition that I've used for my test:
<FIELD name="WitTriage" refname="TfsWitExtensions.Triage" type="String" reportable="dimension">
 <HELPTEXT>Status of triaging the bug</HELPTEXT>
 <SUGGESTEDVALUES expanditems="false">
 <LISTITEM value="[Approved]" />
 <LISTITEM value="[Investigate]" />
 <LISTITEM value="[Rejected]" />
 <LISTITEM value="[Submit]" />
 </SUGGESTEDVALUES>
 </FIELD>

<Control Type="MultiValueControl" FieldName="TfsWitExtensions.Triage" Label="Triag&amp;e:" LabelPosition="Left" />              
Give it a try and see if you're getting the same error with this definition.
Jul 11, 2016 at 5:33 PM
Edited Jul 12, 2016 at 6:12 PM
The following is from my WIT template. I just confirmed: This works in Visual Studio but not the web interface. We just applied 2015 update 3:
<FIELD name="Subject Matter Expert 1" refname="Microsoft.VSTS.CMMI.SubjectMatterExpert1" type="String">
  <ALLOWEXISTINGVALUE />
  <VALIDUSER />
  <SUGGESTEDVALUES expanditems="true">
    <GLOBALLIST name="RequirementsSME" />
  </SUGGESTEDVALUES>
</FIELD>
Global List
<GLOBALLIST name="RequirementsSME">
  <LISTITEM value="[ ]" />
  <LISTITEM value="[David Jones]" />
  <LISTITEM value="[Brian Adams]" />
</GLOBALLIST>

<Control FieldName="Microsoft.VSTS.CMMI.SubjectMatterExpert1" Type="MultiValueControl" Label="Subject Matter Experts" LabelPosition="Left" ></Control>
The result on the Web interface is an empty dropdown.
Jul 13, 2016 at 1:52 PM
Edited Jul 13, 2016 at 1:54 PM
To follow up: I determined the issue only occurs when the control uses a Microsoft.VSTS.CMMI.* field. I created a new control against the Microsoft.VSTS.CMMI.ActualAttendee8 control using the global list with the same result: This works in VS but not on the web interface.

(I confirmed the global list is not the issue: I created the "TfsWitExtensions.Triage" as above and the global list works fine)
Developer
Jul 14, 2016 at 8:51 AM
Thanks for the follow-up, it does sound strange that some fields won't work. I'll try to repro on my side and follow up with you.
Aug 31, 2016 at 1:42 PM
Is there any update to this? I am having a similar problem. The check box appears in VS, but not on the Web.
In TFS 2015 Update the I am assuming that this control gets installed as a "Legacy Extension"?

<Control FieldName="WPS.TechnologyDomain" Type="FieldControl" Label="Technology Domain" LabelPosition="Left" PreferredType="MultiValueControl" />
 <FIELD name="Technology Domain" refname="WPS.TechnologyDomain" type="String" reportable="dimension">
    <SUGGESTEDVALUES expanditems="true">
      <LISTITEM value="[Item 1]" />
      <LISTITEM value="[item 2]" />
    </SUGGESTEDVALUES>
  </FIELD>