TFS2015 WebAccess not working

Topics: Developer Forum
May 19, 2015 at 11:47 PM
Hi,

I noticed that the WebAccess plugin is not working on TFS2015 RC. Is there already started with migrating the Plugin?
May 20, 2015 at 6:41 AM
Thanks for the feedback. I'll try to get it updated for 2015 this week.
May 26, 2015 at 11:10 AM
Edited May 26, 2015 at 11:10 AM
Hi,

Is there any update on when there may be a download for 2015? Upgraded a test environment to TFS 2015 and would be nice test as we use the current version on our 2013 environment

Thanks
Andy
Jun 4, 2015 at 10:49 AM
Is there any further news on this?
Jun 4, 2015 at 3:17 PM
Hi Andy,

We're working on an updated, I hope we can get it out this week.

Mathias
Jun 5, 2015 at 8:09 AM
Hi,

we are also interested in a version for VS2015 and TFS2015. I've tried compiling the code (works fine) and deploying it (doesn't work)

Cheers,
Roel
Jun 7, 2015 at 4:45 PM
Hi,

I was able to make the control work in VS2015RC. The sole required change is to update thereferences in the WitCustomControls project to the new version for the following dlls:
  • Microsoft.TeamFoundation.Client
  • Microsoft.TeamFoundation.Common
  • Microsoft.TeamFoundation.WorkItemTracking.Client
  • Microsoft.TeamFoundation.WorkItemTracking.Controls
On my machine I took the new .dlls from the path: "C:\Program Files\Common Files\microsoft shared\Team Foundation Server\14.0"

Now lets takle the web version...

Regards

Stéphane
Jun 13, 2015 at 9:39 AM
We've published a beta for 2015 RC here R1.3.0.0.

Download the let us know if there are any issues.

Mathias
Jun 16, 2015 at 3:08 PM
works brilliantly :) thanks!
Jun 17, 2015 at 12:48 AM
Thanks it now works perfectly!
Jun 17, 2015 at 8:05 AM
Excellent news, thanks for your feedback. I will mark the release as stable for the 2015 RC and test it again against RTM.
Dec 1, 2015 at 11:56 PM
The custom controls work with VS2015 Update 1 but the web access extension doesn't work with TFS2015 Update 1. It throws up an error like this:

"Script error for: /tfs/_plugins/4422/CodePlex.WitCustomControls.MultiValueControl http://requirejs.org/docs/errors.html#scripterror"
Dec 19, 2015 at 5:01 PM
I just checked this and on my TFS 2015 Update environment the 1.3.1.0 release works just fine. Can you check that you've tested the same versions (i.e. TFS 14.0.24712.0 and WitCustomControls 1.3.1.0)?
Jan 29, 2016 at 11:58 AM
Edited Jan 29, 2016 at 12:22 PM
Hi we have TFS 2015 version 14.0.24712.0 Update 1. I downloaded WitCustomControls 1.3.1.0.

I used process template editor to export the wit added a new field from VS and also mentioned PreferredType as well.

I installed the extension from web too.

It is working good on VS 2015 client. However in webaccess it is not showing checkbox to select. Any idea?

I have IE11

Please help