MultiValue Control won't update itself when other fields change

Topics: Developer Forum, Project Management Forum, User Forum
Jun 2, 2014 at 7:43 AM
Edited Jun 2, 2014 at 12:20 PM
Hi,
We have setup the 'MultiValue Control' on our servers, and its working really great but we have a little problem.

We have a field that it's allowed/suggested values is dependent on the value from another field,
a simple 'WHEN' rule in TFS:
<FieldValueCondition field="Custom.OS" value="Windows">
  <SUGGESTEDVALUES expanditems="true">
    <LISTITEM value="Value1" />
    <LISTITEM value="Value2" />
  </SUGGESTEDVALUES>
</FieldValueCondition>
It works great, but we want now that, the dependent field will be a MultiValue control.

Changed the values to include braces ([Value1],[Value2] etc..) and changed the field to be of type MultiValue control.

When changing the parent field (the field that will influence the other) - nothing happens in the dependent field, we have to first save the workitem, refresh the page and then the multivalue control will update..

This is before the change:
Image

After change (no save):
Image

After with save and page refresh:
Image

The multivalue control wont "fire" its update event after changing a field, only after page refresh, what can we do?

Thanks
Developer
Jun 26, 2014 at 9:05 PM
Hmm, not sure if this is a scenario we've tested. I will setup a test and see what we can do.
Jul 6, 2014 at 8:45 AM
Hi, any news about this?
Jul 31, 2014 at 9:59 AM
.........?
Developer
Jul 31, 2014 at 11:42 AM
Totally forgot this over the summer :-( I will take a look this week.
Aug 11, 2014 at 12:27 PM
Edited Aug 12, 2014 at 8:41 PM
Any news?
Developer
Aug 12, 2014 at 7:57 PM
We're looking into it but the short answer is that's there's no support for this implemented, We're investigating what would be required to add the support, I will post back with what we find.
Dec 4, 2014 at 8:44 AM
MOlausson wrote:
We're looking into it but the short answer is that's there's no support for this implemented, We're investigating what would be required to add the support, I will post back with what we find.
Any progress / news on that?