Multivalue control doesn't work in Web access - TFS 2012 or 2013

Topics: Developer Forum, User Forum
Mar 11, 2014 at 6:52 PM
I have TFS 2012 and TFS 2013 and uploading the 1.2.0.0 zip at .../_admin/_extensions in either doesn't give me the checkboxes. I see them in VS2013 just fine, but web access, nothing. Was there something else I should have done on the TFS app tier server? Perhaps run the .msi on the TFS server? The zip on CodePlex has 2 files in it, a zip and .msi. I uploaded the zip that I found in side the original zip and uploaded that to _admin/_extensions. I only ran the .msi locally on my machine, that's probably why I see it fine in VS2013 team explorer. But again, I don't see checkboxes in web access view.
Mar 13, 2014 at 1:07 AM
Edited Mar 13, 2014 at 3:12 AM
Hi,

What you tried seams appropriate.

You only need to run the .msi locally and it is used only thru visual studio. There are separate .msi for vs2012 and vs2013. No need to install thoses on the server exept if you use it as a workstation with VS.

The enclosed .zip file needs to be uploaded in the extensions thru web access as you found. Here also you have separate version for tfs2012 and tfs2013.

Just for clariry, after uploading, you need to enable the extension.

Could you tell a bit more about the browser and version you are using?

Also, is there a message displayed on the work item in place of the checkbox control?

Stéphane
Mar 13, 2014 at 3:53 PM
Thanks for the reply.

I'm running the 2013 bits on our tfs 2013 instance (it's our dev instance now, working on upgrade)
And I'm running the 2012 bits on our tfs 2012 (test, stage, production)

The extension is indeed enabled. Tried disabling then re-enabling. Also tried an iisreset on the 2013 instance.

My browser is IE10.
10.0.9200.16798
update versions: 10.0.13 (KB2909921)

There is no message displayed on the work item in place of the control. The control in fact renders just fine, just no little checkboxes. : (

So I'm using from Team Explorer, but not everyone uses Team Explorer client, others (PMs and BAs) use web access. Have high hopes for your control, will really be most useful.

Thanks.
Mar 13, 2014 at 8:43 PM
Based on the fact you're stating that the regular dropdown control still renders fine, it probably means you did not change the type of the control for the specific fields on which you want a multiselect.
To do this you need to edit the work item definition (in the layout tab once you have installed the tfs power tools) and set the type of the control for the field on which you need it explicitly to the multivalue control.
Simply executing the setup and registering the extension as you did will not turn every dropdown into a multivalue control. You have to explicitly set this for each field in the wit.

Hope this helps.


Van: tjdev
Verzonden: 13/03/2014 15:54
Aan: [email removed]
Onderwerp: Re: Multivalue control doesn't work in Web access - TFS 2012 or 2013 [WitCustomControls:538667]

From: tjdev

Thanks for the reply.

I'm running the 2013 bits on our tfs 2013 instance (it's our dev instance now, working on upgrade)
And I'm running the 2012 bits on our tfs 2012 (test, stage, production)

The extension is indeed enabled. Tried disabling then re-enabling. Also tried an iisreset on the 2013 instance.

My browser is IE10.
10.0.9200.16798
update versions: 10.0.13 (KB2909921)

There is no message displayed on the work item in place of the control. The control in fact renders just fine, just no little checkboxes. : (

So I'm using from Team Explorer, but not everyone uses Team Explorer client, others (PMs and BAs) use web access. Have high hopes for your control, will really be most useful.

Thanks.
Marked as answer by MOlausson on 6/18/2014 at 1:19 PM
Mar 14, 2014 at 4:17 PM
Brilliant - fixed! And I thought I went in there to check that. I noticed in the demo xml snippet (creating the property by hand for import rather than opening wit from server) that it had Type and PreferredType attributes (e.g. <Control FieldName="My.Test.Control" Type="FieldControl" PreferredType="MultiValueControl" yada..../>), and that was enough for Team Explorer. I never went back to the Layout tab using 'open wit from server' and just flat out changed the Type....which..duh...I could do, too (right?), in the xml snippet, too.

Again - many thanks for the personal service and fast responses.

Issue resolved and case closed.