Issue after upgrading to TFS 2013

Topics: Developer Forum, User Forum
Dec 28, 2013 at 7:56 AM
Hi,

We have been using your MultiValueControl in TFS 2012 and loved it. After upgrading to TFS 2013, the control seems to break our work items that use it.

We don't see any errors, but all the fields are blank, including lists in the drop down fields.

Do you have any idea what could be causing this problem?
Dec 28, 2013 at 8:16 AM
Edited Dec 28, 2013 at 8:17 AM
I'm sorry to hear it's not working for you. To help us understand your environment can you check the following:
  • Does it work in Visual Studio 2013?
  • Does it work in Visual Studio 2012?
  • Does it work in TFS Web Access?
Also if you could provide a field definition we can try to repro the issue.

Thanks,
Mathias
Dec 28, 2013 at 8:44 AM
Thanks for pointing out VS 2013, I do get an error there.
Products contains a value that is not supported by the multiple value control because it is either empty or does not properly separate its values by enclosing them square brackets. The string representing multiple values should be of the form “[value 1];[value 2]”.
Our list hasn't changed, so I don't know why this error is popping up after the upgrade.
  • I don't have a copy of VS 2012 to test this out, I'll get back to you when I can find someone who can.
  • Web Access is where I noticed the issue.
Here's a snippet of what we are doing,
<FIELD name="Products" refname="VSTS.Products" type="String" reportable="dimension">
        <SUGGESTEDVALUES expanditems="true">
          <GLOBALLIST name="Products" />
        </SUGGESTEDVALUES>
        <DEFAULT from="value" value="[none]" />
</FIELD>
And in the form,
<Control FieldName="VSTS.Products" Type="MultiValueControl" Label="Product(s)" LabelPosition="Left" Name="Products">
  <CustomControlOptions />
</Control>
Dec 28, 2013 at 9:11 AM
Edited Dec 28, 2013 at 9:11 AM
Ok, I see what the problem is, the code expects values to be enclosed with square brackets (i.e. [Product1], [Product2] etc). I'll have to check if this is something that's changed for the latest release but I believe it is the same. Perhaps the (Web access) code has been more forgiving before but that's how it's supposed to work.

I will try to reproduce your scenario with the code you posted. If possible you could test adding brackets and see if that solves your issue. See https://witcustomcontrols.codeplex.com/wikipage?title=Multivalue%20control&referringTitle=Home for how to use the control.
Dec 29, 2013 at 12:34 AM
I probably should have mentioned the brackets in my last post, but we are enclosing our items in brackets.
Dec 29, 2013 at 1:36 PM
Edited Dec 29, 2013 at 1:37 PM
I've tried your exact configuration without any issues. Can you try downloading the latest bits and see if it helps (1.2.1.0, beta)? You can pick it up from here: [https://witcustomcontrols.codeplex.com/releases/view/116312].
Dec 30, 2013 at 1:14 PM
Ahshih,

Could you share your Global list definition with us to take a look at? EMail me directly if you don't want to post it here.

Mathias
Dec 30, 2013 at 5:08 PM
We were able to find out what the issue was. There were some issues with our global lists and after correcting them, we were able to get the controls working.

Thanks for helping me out though, I really appreciate it.
Marked as answer by MOlausson on 12/31/2013 at 4:12 AM
Dec 31, 2013 at 8:37 AM
Glad to hear you worked it out!